using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[([s)][^]\n]+([]]|\n|$)";
string input = @"aaa [aaa] aaa [aaa] aa [aaa
[aaaa] aa
aa
[aaja
aaa
[aaa
a";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}