$re = '/[([s)][^]\n]+([]]|\n|$)/';
$str = 'aaa [aaa] aaa [aaa] aa [aaa
[aaaa] aa
aa
[aaja
aaa
[aaa
a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);