re = /[([s)][^]\n]+([]]|\n|$)/
str = 'aaa [aaa] aaa [aaa] aa [aaa
[aaaa] aa
aa
[aaja
aaa
[aaa
a'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end