#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?:0[1-9])|(?:[12][0-9])|(?:3[01])|[1-9])"
Local $sString = "29-02-2016 00:00:46.676 [qtp1746080167-2900285] [ERROR] DefaultDao - Error executing query." & @CRLF & _
"java.lang.Exception: Update count not satisfied." & @CRLF & _
" at com.til.etwealth.etmoney.db.entity.query.sql."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")