using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:0[1-9])|(?:[12][0-9])|(?:3[01])|[1-9])";
string input = @"29-02-2016 00:00:46.676 [qtp1746080167-2900285] [ERROR] DefaultDao - Error executing query.
java.lang.Exception: Update count not satisfied.
at com.til.etwealth.etmoney.db.entity.query.sql.";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}