using System;
using System.Text.RegularExpressions;
public class Example
{
    public static void Main()
    {
        string pattern = @"(\$this\-\>then.*?;)(\$this\-\>and.*?;){0,}";
        string input = @"$this->givenUser1HasPermissionToGroup();$this->andGroupHasPermissionToPortal();$this->andGroupHasPermissionToDevice();$this->andGroupHasPermissionToDataSource1();$this->whenGroupIsDeleted();$this->thenGroupIsntInUser1sPermissions();$this->andGroupIsntInDevicesMemberList();$this->User1HasntPermissionToPortal();$this->andUser1HasntPermissionToDevice();$this->andUser1HasntPermissionToDataSource1();$this->givenUser1HasPermissionToGroup();$this->andUser1HasPermissionToPortal();$this->andGroupHasPermissionToPortal();$this->andPortalHasDevice();$this->andPortalHasDataSource1();$this->andDeviceHasDataSource2();$this->whenPortalIsDeleted();$this->thenPortalIsntInUser1sPermissions();$this->andPortalIsntInGroupsPermissions();$this->andDeviceIsntExistent();$this->andDataSource1IsntExistent();$this->andDataSource2IsntExistent();$this->givenUser1HasPermissionToGroup();$this->andUser1HasPermissionToDevice();$this->andGroupHasPermissionToDevice();$this->andDeviceHasDataSource2();";
        
        foreach (Match m in Regex.Matches(input, pattern))
        {
            Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
        }
    }
}