const regex = /(\$this\-\>then.*?;)(\$this\-\>and.*?;){0,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\$this\\-\\>then.*?;)(\\$this\\-\\>and.*?;){0,}', 'g')
const str = `\$this->givenUser1HasPermissionToGroup();\$this->andGroupHasPermissionToPortal();\$this->andGroupHasPermissionToDevice();\$this->andGroupHasPermissionToDataSource1();\$this->whenGroupIsDeleted();\$this->thenGroupIsntInUser1sPermissions();\$this->andGroupIsntInDevicesMemberList();\$this->User1HasntPermissionToPortal();\$this->andUser1HasntPermissionToDevice();\$this->andUser1HasntPermissionToDataSource1();\$this->givenUser1HasPermissionToGroup();\$this->andUser1HasPermissionToPortal();\$this->andGroupHasPermissionToPortal();\$this->andPortalHasDevice();\$this->andPortalHasDataSource1();\$this->andDeviceHasDataSource2();\$this->whenPortalIsDeleted();\$this->thenPortalIsntInUser1sPermissions();\$this->andPortalIsntInGroupsPermissions();\$this->andDeviceIsntExistent();\$this->andDataSource1IsntExistent();\$this->andDataSource2IsntExistent();\$this->givenUser1HasPermissionToGroup();\$this->andUser1HasPermissionToDevice();\$this->andGroupHasPermissionToDevice();\$this->andDeviceHasDataSource2();`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}