import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\$this\\-\\>then.*?;)(\\$this\\-\\>and.*?;){0,}";
final String string = "$this->givenUser1HasPermissionToGroup();$this->andGroupHasPermissionToPortal();$this->andGroupHasPermissionToDevice();$this->andGroupHasPermissionToDataSource1();$this->whenGroupIsDeleted();$this->thenGroupIsntInUser1sPermissions();$this->andGroupIsntInDevicesMemberList();$this->User1HasntPermissionToPortal();$this->andUser1HasntPermissionToDevice();$this->andUser1HasntPermissionToDataSource1();$this->givenUser1HasPermissionToGroup();$this->andUser1HasPermissionToPortal();$this->andGroupHasPermissionToPortal();$this->andPortalHasDevice();$this->andPortalHasDataSource1();$this->andDeviceHasDataSource2();$this->whenPortalIsDeleted();$this->thenPortalIsntInUser1sPermissions();$this->andPortalIsntInGroupsPermissions();$this->andDeviceIsntExistent();$this->andDataSource1IsntExistent();$this->andDataSource2IsntExistent();$this->givenUser1HasPermissionToGroup();$this->andUser1HasPermissionToDevice();$this->andGroupHasPermissionToDevice();$this->andDeviceHasDataSource2();";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}