#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\w\:]+\:\w+)|(([\d\.]+))"
Local $sString = "1200:0000:AB00:1234:0000:2552:7777:1313" & @CRLF & _
"21DA:D3:0:2F3B:2AA:FF:FE28:9C5A" & @CRLF & _
"FE80:0000:0000:0000:0202:B3FF::8329 " & @CRLF & _
"0.0.0.0" & @CRLF & _
"9.255.255.255" & @CRLF & _
"11.0.0.0" & @CRLF & _
"126.255.255.255" & @CRLF & _
"129.0.0.0" & @CRLF & _
"169.253.255.255" & @CRLF & _
"169.255.0.0" & @CRLF & _
"172.15.255.255" & @CRLF & _
"172.32.0.0" & @CRLF & _
"191.0.1.255" & @CRLF & _
"192.88.98.255" & @CRLF & _
"192.88.100.0" & @CRLF & _
"192.167.255.255" & @CRLF & _
"192.169.0.0" & @CRLF & _
"198.17.255.255" & @CRLF & _
"223.255.255.255"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")