const regex = /([\w\:]+\:\w+)|(([\d\.]+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w\\:]+\\:\\w+)|(([\\d\\.]+))', 'gm')
const str = `1200:0000:AB00:1234:0000:2552:7777:1313
21DA:D3:0:2F3B:2AA:FF:FE28:9C5A
FE80:0000:0000:0000:0202:B3FF::8329
0.0.0.0
9.255.255.255
11.0.0.0
126.255.255.255
129.0.0.0
169.253.255.255
169.255.0.0
172.15.255.255
172.32.0.0
191.0.1.255
192.88.98.255
192.88.100.0
192.167.255.255
192.169.0.0
198.17.255.255
223.255.255.255`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}