import Foundation
let pattern = #"([\w\:]+\:\w+)|(([\d\.]+))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1200:0000:AB00:1234:0000:2552:7777:1313
21DA:D3:0:2F3B:2AA:FF:FE28:9C5A
FE80:0000:0000:0000:0202:B3FF::8329
0.0.0.0
9.255.255.255
11.0.0.0
126.255.255.255
129.0.0.0
169.253.255.255
169.255.0.0
172.15.255.255
172.32.0.0
191.0.1.255
192.88.98.255
192.88.100.0
192.167.255.255
192.169.0.0
198.17.255.255
223.255.255.255
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)