#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "catid=396(&|$)"
Local $sString = "meine-domian.de/index.php?option=com_content&view=article&id=3045:artikel-alias&catid=396&Itemid=223&lang=de"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")