re = /catid=396(&|$)/
str = 'meine-domian.de/index.php?option=com_content&view=article&id=3045:artikel-alias&catid=396&Itemid=223&lang=de'
# Print the match result
str.match(re) do |match|
puts match.to_s
end