package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`catid=396(&|$)`)
var str = `meine-domian.de/index.php?option=com_content&view=article&id=3045:artikel-alias&catid=396&Itemid=223&lang=de`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}