using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-zA-Z0-9\.\-\_])+\@([a-zA-Z0-9])+\.([a-zA-Z0-9]{3,5})$";
string substitution = @"";
string input = @"ericabraham.ea@gmail.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}