re = /^([a-zA-Z0-9\.\-\_])+\@([a-zA-Z0-9])+\.([a-zA-Z0-9]{3,5})$/
str = 'ericabraham.ea@gmail.com'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result