const regex = /^([a-zA-Z0-9\.\-\_])+\@([a-zA-Z0-9])+\.([a-zA-Z0-9]{3,5})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z0-9\\.\\-\\_])+\\@([a-zA-Z0-9])+\\.([a-zA-Z0-9]{3,5})$', '')
const str = `ericabraham.ea@gmail.com`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);