using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D*\(?(\d{3})?\)?\D*(\d{4})\D*(\d{4})";
string input = @"50378511074";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}