package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\D*\(?(\d{3})?\)?\D*(\d{4})\D*(\d{4})`)
var str = `50378511074`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}