$re = '/\D*\(?(\d{3})?\)?\D*(\d{4})\D*(\d{4})/';
$str = '50378511074';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);