package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\b(?<digit>\p{N}+)|(?<word>\p{L}+)\b)|(?<rest>[^\p{Z}]+)`)
var str = `There are usually 100 to 200 words ++ -- ** in a paragraph`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}