const regex = /(?:\b(?<digit>\p{N}+)|(?<word>\p{L}+)\b)|(?<rest>[^\p{Z}]+)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b(?<digit>\\p{N}+)|(?<word>\\p{L}+)\\b)|(?<rest>[^\\p{Z}]+)', 'gmu')
const str = `There are usually 100 to 200 words ++ -- ** in a paragraph`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}