const regex = /[\n\r]*.*function.*(.*).*{.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\n\\r]*.*function.*(.*).*{.*', '')
const str = `Amazon.com: Sony XBR-65X900A 65-Inch 4K Ultra HD 120Hz 3D LED UHDTV (2013 Model): Electronics`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}