import re
regex = re.compile(r"[\n\r]*.*function.*(.*).*{.*")
test_str = "Amazon.com: Sony XBR-65X900A 65-Inch 4K Ultra HD 120Hz 3D LED UHDTV (2013 Model): Electronics"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")