re = /[\n\r]*.*function.*(.*).*{.*/
str = 'Amazon.com: Sony XBR-65X900A 65-Inch 4K Ultra HD 120Hz 3D LED UHDTV (2013 Model): Electronics'
# Print the match result
str.match(re) do |match|
puts match.to_s
end