using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<|\G(?<=(?:<|"")).*?(?:>|""(.*?)""))";
string input = @"<a href=""http://www.google.com"" alt=""foobar"">""hello""world</a>
<img src=""yop"">";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}