$re = '/(?:<|\G(?<=(?:<|")).*?(?:>|"(.*?)"))/';
$str = '<a href="http://www.google.com" alt="foobar">"hello"world</a>
<img src="yop">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);