re = /(?:<|\G(?<=(?:<|")).*?(?:>|"(.*?)"))/
str = '<a href="http://www.google.com" alt="foobar">"hello"world</a>
<img src="yop">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end