import re
regex = re.compile(r"(?'pair'(?'d'-)(?'lcv'\w+)(?'s'\s)(?'dol'\$)(?'o'\()(?'ucv'\w+)(?'c'\)))(?'es'\n?)")
test_str = ("-solutionName $(SolutionName)\n"
"-solutionAbbreviation $(SolutionAbbreviation)\n"
"-projectName $(ProjectName)\n"
"-projectAbbreviation $(ProjectAbbreviation)\n"
"-environmentAbbreviation $(EnvironmentAbbreviation)\n"
"-appServicePlanAbbreviation $(AppServicePlanAbbreviation)\n"
"-logicAppAbbreviation $(LogicAppAbbreviation)\n"
"-serviceBusNamespaceAbbreviation $(ServiceBusNamespaceAbbreviation)\n"
"-serviceBusQueueAbbreviation $(ServiceBusQueueAbbreviation)\n"
"-scanAppServicePlanLocation $(ScanAppServicePlanLocation)\n"
"-scanAppServicePlanSKUName $(ScanAppServicePlanSKUName)\n"
"-scanAppServicePlanSKUTier $(ScanAppServicePlanSKUTier)\n"
"-scanAppServicePlanNumberOfWorkers $(ScanAppServicePlanNumberOfWorkers)\n"
"-hockeyAppAPIUri $(HockeyAppAPIUri)\n"
"-hockeyAppAPIAuthenticationTenant $(HockeyAppAPIAuthenticationTenant)\n"
"-hockeyAppAPIAuthenticationAudience $(HockeyAppAPIAuthenticationAudience)\n"
"-hockeyAppAPIAuthenticationClientId $(HockeyAppAPIAuthenticationClientId)\n"
"-hockeyAppAPIAuthenticationSecret $(HockeyAppAPIAuthenticationSecret)\n"
"-hockeyAppAPIPollingInterval $(HockeyAppAPIPollingInterval)\n"
"-scanQueueNamespaceKind $(ScanQueueNamespaceKind)\n"
"-scanQueueNamespaceSkuName $(ScanQueueNamespaceSkuName)\n"
"-scanQueueNamespaceSkuTier $(ScanQueueNamespaceSkuTier)\n"
"-scanQueueNamespaceLocation $(ScanQueueNamespaceLocation)\n"
"-scanQueueNamespaceAuthorizationRulesLocation $(ScanQueueNamespaceAuthorizationRulesLocation)\n\n")
subst = "${pair}"
result = regex.sub(subst, test_str)
if result:
print(result)