import Foundation
let pattern = #"(?'pair'(?'d'-)(?'lcv'\w+)(?'s'\s)(?'dol'\$)(?'o'\()(?'ucv'\w+)(?'c'\)))(?'es'\n?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
-solutionName $(SolutionName)
-solutionAbbreviation $(SolutionAbbreviation)
-projectName $(ProjectName)
-projectAbbreviation $(ProjectAbbreviation)
-environmentAbbreviation $(EnvironmentAbbreviation)
-appServicePlanAbbreviation $(AppServicePlanAbbreviation)
-logicAppAbbreviation $(LogicAppAbbreviation)
-serviceBusNamespaceAbbreviation $(ServiceBusNamespaceAbbreviation)
-serviceBusQueueAbbreviation $(ServiceBusQueueAbbreviation)
-scanAppServicePlanLocation $(ScanAppServicePlanLocation)
-scanAppServicePlanSKUName $(ScanAppServicePlanSKUName)
-scanAppServicePlanSKUTier $(ScanAppServicePlanSKUTier)
-scanAppServicePlanNumberOfWorkers $(ScanAppServicePlanNumberOfWorkers)
-hockeyAppAPIUri $(HockeyAppAPIUri)
-hockeyAppAPIAuthenticationTenant $(HockeyAppAPIAuthenticationTenant)
-hockeyAppAPIAuthenticationAudience $(HockeyAppAPIAuthenticationAudience)
-hockeyAppAPIAuthenticationClientId $(HockeyAppAPIAuthenticationClientId)
-hockeyAppAPIAuthenticationSecret $(HockeyAppAPIAuthenticationSecret)
-hockeyAppAPIPollingInterval $(HockeyAppAPIPollingInterval)
-scanQueueNamespaceKind $(ScanQueueNamespaceKind)
-scanQueueNamespaceSkuName $(ScanQueueNamespaceSkuName)
-scanQueueNamespaceSkuTier $(ScanQueueNamespaceSkuTier)
-scanQueueNamespaceLocation $(ScanQueueNamespaceLocation)
-scanQueueNamespaceAuthorizationRulesLocation $(ScanQueueNamespaceAuthorizationRulesLocation)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${pair}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)