#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:st=([^&\n]*))?&?(?:c=([^&\n]*))?&?(?:t=([^&\n]*))?&?(?:k=([^&\n]*))? HTTP$"
Local $sString = "st=expand&c=22&t=button&k=fun HTTP" & @CRLF & _
"c=22&t=button&k=fun HTTP" & @CRLF & _
"st=expand&c=22&t=party&k=fun HTTP" & @CRLF & _
"st=expand&c=22&k=fun HTTP" & @CRLF & _
"st=expand HTTP" & @CRLF & _
" HTTP"
Local $sSubst = "\1,\2,\3,\4"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)