$re = '/^(?:st=([^&\n]*))?&?(?:c=([^&\n]*))?&?(?:t=([^&\n]*))?&?(?:k=([^&\n]*))? HTTP$/m';
$str = 'st=expand&c=22&t=button&k=fun HTTP
c=22&t=button&k=fun HTTP
st=expand&c=22&t=party&k=fun HTTP
st=expand&c=22&k=fun HTTP
st=expand HTTP
HTTP';
$subst = "\1,\2,\3,\4";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;