use strict;
my $str = 'st=expand&c=22&t=button&k=fun HTTP
c=22&t=button&k=fun HTTP
st=expand&c=22&t=party&k=fun HTTP
st=expand&c=22&k=fun HTTP
st=expand HTTP
HTTP';
my $regex = qr/^(?:st=([^&\n]*))?&?(?:c=([^&\n]*))?&?(?:t=([^&\n]*))?&?(?:k=([^&\n]*))? HTTP$/mp;
my $subst = '\\1,\\2,\\3,\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";