#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)((?<!\d|\.)([0-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])(?!\d|\.) *[,;] *){2}(?<!\d|\.)([0-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])(?!\d|\.)"
Local $sString = "RGBA: (0-255) 204, 128, 128, 255" & @CRLF & _
"RGBA: (0-255) 4, 128, 128, 255" & @CRLF & _
"RGBA: (0-255) 204, 18, 928, 255" & @CRLF & _
"RGBA: (0-255) 304, 1, 18, 255" & @CRLF & _
"RGBA: (0-255) 204, 28, 128, 25, 25, 255, 152, 12" & @CRLF & _
"RGBA: (0-255) 204, 128, 8, 5" & @CRLF & _
"RGBA: (0-255) 204, 128, 128, 355" & @CRLF & _
"RGBA: (0-255) 204, 128, 128, 265" & @CRLF & _
"RGBA: (0-255) 204, 128, 128, 256" & @CRLF & _
"" & @CRLF & _
"bonjour, 18, 928, 255" & @CRLF & _
"" & @CRLF & _
"RGBA: (0-1) 0.8, 0.502, 0.502, 1" & @CRLF & _
"RGB: #cc8080" & @CRLF & _
"RGBA: #cc8080ff" & @CRLF & _
"ARGB: #ffcc8080" & @CRLF & _
"CMYK: 0, 37, 37, 19" & @CRLF & _
"HSLA: 360, 43, 65, 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")