use strict;
my $str = 'RGBA: (0-255) 204, 128, 128, 255
RGBA: (0-255) 4, 128, 128, 255
RGBA: (0-255) 204, 18, 928, 255
RGBA: (0-255) 304, 1, 18, 255
RGBA: (0-255) 204, 28, 128, 25, 25, 255, 152, 12
RGBA: (0-255) 204, 128, 8, 5
RGBA: (0-255) 204, 128, 128, 355
RGBA: (0-255) 204, 128, 128, 265
RGBA: (0-255) 204, 128, 128, 256
bonjour, 18, 928, 255
RGBA: (0-1) 0.8, 0.502, 0.502, 1
RGB: #cc8080
RGBA: #cc8080ff
ARGB: #ffcc8080
CMYK: 0, 37, 37, 19
HSLA: 360, 43, 65, 1';
my $regex = qr/((?<!\d|\.)([0-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])(?!\d|\.) *[,;] *){2}(?<!\d|\.)([0-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])(?!\d|\.)/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}