$re = '/((?<!\d|\.)([0-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])(?!\d|\.) *[,;] *){2}(?<!\d|\.)([0-9]?[0-9]|1[0-9][0-9]|2[0-4][0-9]|25[0-5])(?!\d|\.)/i';
$str = 'RGBA: (0-255) 204, 128, 128, 255
RGBA: (0-255) 4, 128, 128, 255
RGBA: (0-255) 204, 18, 928, 255
RGBA: (0-255) 304, 1, 18, 255
RGBA: (0-255) 204, 28, 128, 25, 25, 255, 152, 12
RGBA: (0-255) 204, 128, 8, 5
RGBA: (0-255) 204, 128, 128, 355
RGBA: (0-255) 204, 128, 128, 265
RGBA: (0-255) 204, 128, 128, 256
bonjour, 18, 928, 255
RGBA: (0-1) 0.8, 0.502, 0.502, 1
RGB: #cc8080
RGBA: #cc8080ff
ARGB: #ffcc8080
CMYK: 0, 37, 37, 19
HSLA: 360, 43, 65, 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);