import re
regex = re.compile(r"\d+[.,]?(\d+\s*k?|x{2,3})(?=\s*(original|actual|highway)?\s*miles)|(?<=mile(s|agex?):?\s*(is|~)?\s*)\d+[.,]?(\d+(\s*k)?|x{2,3})|(\d+(\s*K)|x{2,3})", flags=re.IGNORECASE)
test_str = "123456789012"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")