#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.*) on (.*) type (.*) \((.*)\)"
Local $sString = "/dev/mapper/precise32-root on / type ext4 (rw,errors=remount-ro)" & @CRLF & _
"proc on /proc type proc (rw,noexec,nosuid,nodev)" & @CRLF & _
"sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)" & @CRLF & _
"none on /sys/fs/fuse/connections type fusectl (rw)" & @CRLF & _
"none on /sys/kernel/debug type debugfs (rw)" & @CRLF & _
"none on /sys/kernel/security type securityfs (rw)" & @CRLF & _
"udev on /dev type devtmpfs (rw,mode=0755)" & @CRLF & _
"devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)" & @CRLF & _
"tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)" & @CRLF & _
"none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)" & @CRLF & _
"none on /run/shm type tmpfs (rw,nosuid,nodev)" & @CRLF & _
"/dev/sda1 on /boot type ext2 (rw)" & @CRLF & _
"rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw)" & @CRLF & _
"/vagrant on /vagrant type vboxsf (uid=1000,gid=1000,rw)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")