import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*) on (.*) type (.*) \\((.*)\\)";
final String string = "/dev/mapper/precise32-root on / type ext4 (rw,errors=remount-ro)\n"
+ "proc on /proc type proc (rw,noexec,nosuid,nodev)\n"
+ "sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)\n"
+ "none on /sys/fs/fuse/connections type fusectl (rw)\n"
+ "none on /sys/kernel/debug type debugfs (rw)\n"
+ "none on /sys/kernel/security type securityfs (rw)\n"
+ "udev on /dev type devtmpfs (rw,mode=0755)\n"
+ "devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)\n"
+ "tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)\n"
+ "none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)\n"
+ "none on /run/shm type tmpfs (rw,nosuid,nodev)\n"
+ "/dev/sda1 on /boot type ext2 (rw)\n"
+ "rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw)\n"
+ "/vagrant on /vagrant type vboxsf (uid=1000,gid=1000,rw)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}