import re
regex = re.compile(r"(.*) on (.*) type (.*) \((.*)\)")
test_str = ("/dev/mapper/precise32-root on / type ext4 (rw,errors=remount-ro)\n"
"proc on /proc type proc (rw,noexec,nosuid,nodev)\n"
"sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)\n"
"none on /sys/fs/fuse/connections type fusectl (rw)\n"
"none on /sys/kernel/debug type debugfs (rw)\n"
"none on /sys/kernel/security type securityfs (rw)\n"
"udev on /dev type devtmpfs (rw,mode=0755)\n"
"devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)\n"
"tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)\n"
"none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)\n"
"none on /run/shm type tmpfs (rw,nosuid,nodev)\n"
"/dev/sda1 on /boot type ext2 (rw)\n"
"rpc_pipefs on /run/rpc_pipefs type rpc_pipefs (rw)\n"
"/vagrant on /vagrant type vboxsf (uid=1000,gid=1000,rw)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")