import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[:]\\s(\\\".*\\\")";
final String string = "\"ElevationFilenameIn\": \"Input raster elevation file\",\n"
+ "\"TargetCRS\": \"Target vertical coordinate reference system Type\",\n"
+ "\"TargetCRScode\": \"Target vertical coordinate system Code\",\n"
+ "\"TargetCRSfile\": \"The projection (.prj) file in shoebox to be used for this inputfile\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}