const regex = /(?<=^\d+ +\w*)\w{3,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^\\d+ +\\w*)\\w{3,}', 'gm')
const str = `820384318 05555946 268 859
820384456 0PM45276 268 859
820384755 KPM53246 268 859 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}