re = /(?<=^\d+ +\w*)\w{3,}/m
str = '820384318 05555946 268 859
820384456 0PM45276 268 859
820384755 KPM53246 268 859 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end