# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((https?:\\/\\/)?[^\s.]+\.[\w][^\s]+)/<a href="$1" target=_blank">$1<\/a>/gm;t' <<< "example.com
example.com/
ExaMp1e.com
example.com/example
example.com/example/
example.example.example.example.com/example
http://www.example.com
http://www.example.com/
http://www.example.com/example
http://www.example.com/example/
www.example.com
www.example.com/example
email@example.com
.
...
example...
.example
.example/
/example
...example
example. Example
1.1v"