#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((https?:\/\/)?[^\s.]+\.[\w][^\s]+)"
Local $sString = "example.com" & @CRLF & _
"example.com/" & @CRLF & _
"ExaMp1e.com" & @CRLF & _
"example.com/example" & @CRLF & _
"example.com/example/" & @CRLF & _
"example.example.example.example.com/example" & @CRLF & _
"http://www.example.com" & @CRLF & _
"http://www.example.com/" & @CRLF & _
"http://www.example.com/example" & @CRLF & _
"http://www.example.com/example/" & @CRLF & _
"www.example.com" & @CRLF & _
"www.example.com/example" & @CRLF & _
"email@example.com" & @CRLF & _
"" & @CRLF & _
"." & @CRLF & _
"..." & @CRLF & _
"example..." & @CRLF & _
".example" & @CRLF & _
".example/" & @CRLF & _
"/example" & @CRLF & _
"...example" & @CRLF & _
"example. Example" & @CRLF & _
"1.1v"
Local $sSubst = "<a href="$1" target=_blank">$1</a>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)