import Foundation
let pattern = #"((https?:\/\/)?[^\s.]+\.[\w][^\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
example.com
example.com/
ExaMp1e.com
example.com/example
example.com/example/
example.example.example.example.com/example
http://www.example.com
http://www.example.com/
http://www.example.com/example
http://www.example.com/example/
www.example.com
www.example.com/example
email@example.com
.
...
example...
.example
.example/
/example
...example
example. Example
1.1v
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$1" target=_blank">$1</a>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)