using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=').*(?=')";
string input = @"COD(CdTypCd_'SPC_fghfh')
COD(CdTypCd_'SPC.,/'][[]\=-09&^%$#@!~*/-*-*/-/-/-*/-*+@#$$%áèÿó')
COD(CdTypCd_'SPC')
COD(CdTypCd_'SPC@#$$áèÿó%')";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}