$re = '/(?<=\').*(?=\')/';
$str = 'COD(CdTypCd_\'SPC_fghfh\')
COD(CdTypCd_\'SPC.,/\'][[]\\=-09&^%$#@!~*/-*-*/-/-/-*/-*+@#$$%áèÿó\')
COD(CdTypCd_\'SPC\')
COD(CdTypCd_\'SPC@#$$áèÿó%\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);