re = /(?<=').*(?=')/
str = 'COD(CdTypCd_\'SPC_fghfh\')
COD(CdTypCd_\'SPC.,/\'][[]\\=-09&^%$#@!~*/-*-*/-/-/-*/-*+@#$$%áèÿó\')
COD(CdTypCd_\'SPC\')
COD(CdTypCd_\'SPC@#$$áèÿó%\')'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end