package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\+\d{2}\s{1,9}\d{2}(?:\s{1,9})?\d{8}|\d{4}(?:\s{1,9}\d{6}(?:\d{4})?|\d(?:\s{1,9})?\d{6})`)
var str = `+99 99 99999999
9999 999999
99999 999999
99999999999
+99 9999999999
9999 9999999999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}